科技网

当前位置: 首页 >VR

apache2.2不能启动[问题_a

VR
来源: 作者: 2020-01-17 03:02:48

apache2.2 不能启动

提示我是httpd.conf里面的116行出错了 LoadModule php5_module "c:/PHP/php5apache2_2.dll" 只要我删除了就能启动

http://dev.csdn.net/article/45/45858.shtm

我配置的也是apache2.2,仔细对照着这个文档就可以配置成功的。。。

--------------模块化安装配置------------------------------------

找到 #LoadModule ssl_module modules/mod_ssl.so 这行,在此行后加入一行

LoadModule php5_module D:/ApacheGroup/Apache2/php5/php5apache2_2.dll

下载wamp最新版本,安装下.里面apache/php/mysql都配好了.你可以看下.

Apache version :Apache/2.2.6 (Win32) PHP version :5.2.5 Loaded extensions :

bcmath, calendar, com_dotnet, ctype, session, filter, ftp, hash, iconv, json, odbc, pcre, Reflection, date, libxml, standard, tokenizer, zlib, SimpleXML, dom, SPL, wddx, xml, xmlreader, xmlwriter, apache2handler, mbstring, mysql, mysqli, PDO, pdo_sqlite, SQLite MySQL version :5.0.45-community-nt

你的问题应该是php部分与apache配置不对.不要删除这行,删除了你的apache就不支持php了.

LoadModule php5_module d:/php/php5apache2.dll

其中d:/php/php5apache2.dll 为你php目录中php5apache2.dll所在的位置,请看下你这目录里是否有这个文件.

安装之前,请完全卸载以前版本的Apache,并删除所有的目录与文件,这是因为新安装的配置文件不会覆盖旧的已经存在的配置文件,旧的文件可能导致Apache服务不能启动。

配置Apache支持PHP

找到 DirectoryIndex index.html index.html.var 在后面加入 index.htm index.php (默认index.php为首页文件)

◆模块化安装PHP

找到 #LoadModule ssl_module modules/mod_ssl.so 这行,在此行后加入一行

LoadModule php5_module d:/php/php/php5apache2.dll

其中d:/php/php/php5apache2.dll 为你php目录中php5apache2.dll所在的位置

再找到 AddType application/x-gzip .gz .tgz 这行,在此行后加入一行

AddType application/x-httpd-php .php

(其实:上面两行红色的,你可以直接加在httpd.conf文件的最后面也可以的)

注意:PHP提供的Php5Apache2.dll居然在Apache2.2.x不适用

解决方法:

下载三个文件.

vcredist_x86.exe

php5apache2.dll

httpd.exe.manifest

1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件.

2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下.

3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步)

完成!去重启你的apache2.2试试吧.

宝宝不消化吃什么好
丁桂薏芽健脾凝胶使用方法
治疗脖子疼的好方法
四磨汤增加大肠蠕动

相关推荐